HSRP - Tracking Using IP SLA
When link between R2 and R1 link goes down.Then Router R2 which is Active for VLAN2 has to be standby but this will not happen so we have to track this line by creating IP SLA or Tracking object which will decrement the priority value regarding respective HSRP.
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------Configuration to create Ip Sla----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Check it by shunting down link FastEthernet0/1 on R2.
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------Now No Shut the link Standby router R2 become Active goes back to configured configurations
----------------------------------------------------------------------------------------------
R2 Configuration
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
track 1 rtr 1 reachability
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 2
ip address 192.168.2.253 255.255.255.0
standby 1 ip 192.168.2.254
standby 1 priority 180
standby 1 preempt
standby 1 track 1 decrement 90
!
interface FastEthernet0/0.2
encapsulation dot1Q 3
ip address 192.168.3.253 255.255.255.0
standby 2 ip 192.168.3.254
standby 2 preempt
!
interface FastEthernet0/1
ip address 30.30.30.40 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router rip
version 2
network 30.0.0.0
network 192.168.2.0
network 192.168.3.0
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ip sla 1
icmp-echo 30.30.30.30 source-ip 30.30.30.40
frequency 10
ip sla schedule 1 life forever start-time now
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R2 Configuration
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
track 1 rtr 1 reachability
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 2
ip address 192.168.2.253 255.255.255.0
standby 1 ip 192.168.2.254
standby 1 priority 180
standby 1 preempt
standby 1 track 1 decrement 90
!
interface FastEthernet0/0.2
encapsulation dot1Q 3
ip address 192.168.3.253 255.255.255.0
standby 2 ip 192.168.3.254
standby 2 preempt
!
interface FastEthernet0/1
ip address 30.30.30.40 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router rip
version 2
network 30.0.0.0
network 192.168.2.0
network 192.168.3.0
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ip sla 1
icmp-echo 30.30.30.30 source-ip 30.30.30.40
frequency 10
ip sla schedule 1 life forever start-time now
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
Comments
Post a Comment